Results 1 to 3 of 3

Thread: What has ahppened to my Chargemaster????

  1. #1
    Join Date
    Oct 2012
    Location
    south Florida
    Posts
    346

    What has happened to my Chargemaster????

    I was loading some 25-06s to go hunting the other day and the read out on the chargemaster has a W or an inverted M on the left side of the screen. Has anyone seen this before or know what it means, or how to make it go away, or has it been there the whole time and I just now noticed it? I am afraid to use it now,even though i checked it against a 505 rcbs and it was only 0.1 of a grain off from the mechanical scale.
    Last edited by ebb; 11-18-2012 at 05:33 PM.

  2. #2
    Join Date
    Jun 2012
    Location
    West central NH
    Posts
    571
    I believe it has to do with the memory feature. It is discussed on page 4 of the pamphlet, "Configure New Load Data Memory", step 6. I think I got that once by mistake. I powered down, back up, recalibrated and it went away. The only issues I have had are long grain powders dumping too much during the trickle process, and the scale not showing the exact same negative number when the pan is removed. Not much you can do about the long grain powders except dump a little back in the hopper and trickle some more (I've got real good at that). The other issue really bugged me. When I first started a load sequence, I would remove the pan and it would read -157.9 or something like that. After 60 or so charges dispensed, it was only reading -157.7. That bothered me a lot, and I tried weighing every 10th charge on a scale. I never caught it being inaccurate, but I called RCBS anyhow. They said wipe the unit all over with a fresh dryer sheet several times while loading. This kind of worked, but I finally ran a ground wire from the metal frame on the bottom of the unit to the massive metal frame of my reloading bench. Problem solved! I now load with confidence.

  3. #3
    Join Date
    Oct 2012
    Location
    south Florida
    Posts
    346
    Thanks vtmarmot, Ive never used the memory on purpose but maybe by accident. Ill reread page 4.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •