PDA

View Full Version : Turbo Action Firing Problem



JohnnyLorick
03-07-2010, 02:59 PM
I have a turbo action and I am having firing problem. The headspace is .042
Sometimes it shoots the 1st time then next it may fire the 2nd or 3rd time.
I have already replaced the firing pin spring and didn't help. I have a cone chamber barrel. If anybody can help with this, please reply. Thanks Johnny Lorick.:confused:

Carp
03-07-2010, 03:14 PM
Be sure the bolt is very clean, inside and out. I used to have a bit of trouble when it was cold. I keep my bolt cleaner than I used to now and don't have any trouble. Did you order your spring from Flash?

John M. Carper

DonMatzeder
03-07-2010, 03:19 PM
Are the case indentions consistent? If so, can you post a picture?

RGORHAM
03-07-2010, 03:32 PM
If you can twist and uncock bolt and show pic of firing pin extrusion and fired case,and were you told it was .042 or did you check I recently had same problem fixed it with firingpin and spring both were light ,firing pin may be short and on old turbos you had to slot trigger hanger and cock pin back further.

JohnnyLorick
03-07-2010, 04:03 PM
I keep bolt very clean, I do have more problems when cold, I have no oil or grease on firing pin spring. Thanks

JohnnyLorick
03-07-2010, 04:04 PM
Yes, the indentions are consistent and well hit. I have no way to post picture. Thanks

JohnnyLorick
03-07-2010, 04:06 PM
No I check it and it was .042 this turbo is 2 years old. Thanks.

David K
03-07-2010, 05:01 PM
Pull Pin and check it for and burrs or to see if the tip has mushroomed any. They sometimes can flatten on the tip. I so it may not be sticking out far enough.

Fred J
03-07-2010, 05:03 PM
Sometimes, the trigger can cause this problem. Flush the trigger with lighter fluid and do not put ant oil in the trigger. It must be dry.